Back to overview
Running
Apr 22, 2026 at 11:10am UTC
Affected services
API
Dashboard
Resolved
Apr 22, 2026 at 11:10am UTC
All the services are running again
Affected services
Resolved
Apr 22, 2026 at 11:10am UTC
All the services are running again
Affected services